Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
9988 views

Drivers tab missing !

Just created a new driverstore and iprint-manager on my OES2 SP2 Box.
When trying to upload some drivers, i could not manage this, because the drivers tab is not there ? Reboot, reinstalling plugins ... nothing helped.

Any idea ?
0 Likes
24 Replies
Absent Member.
Absent Member.

Ditto. We just upgraded using yast online channel upgrade path from oes2sp1/sles10sp2 to oes2sp2/sles10sp3, after successfully going through the upgrade process we are seeing the same issue. In iMan / iManager we go to Manage Driver Store of any of our 3 driver stores and the Drivers tab is missing.

If I go to one of our older oes2sp1/sles10sp2 iManager the Driver tab is there

I've also tried to uninstall and reinstall the iPrint iManager plugin (version 20090924) without any success (restarted tomcat5 daemon afterwards with the uninstall and reinstall).

Help! Thanks!
0 Likes
Absent Member.
Absent Member.

We tried all the possible scanrios of upgrade like form yast, rug and plain upgarde, we didn't hit this issue. So can you please provide more clarity on this so that we can try to reproduce this in our lab.

Thanks in advance,
Raghavendra SR
0 Likes
Absent Member.
Absent Member.

Hi,

had the same issue...
Try this:
Go to iManager / Configure / Rolde based Services / RBS configuration
Click your RBS 2 object
Choose Property Book tab, choose Manage Driver Store, select Actions / Page
List
There you can move "Drivers" page from Available to Assigned
Logout iManager and try it out.

FYI, I have what seems to be previous version of "Drivers" page on "Assigned
pages" and they look like "No Name / iPrintX.DriverStoreXP
iPrintX.DriverStoreW200 ..."

Regs,
Mare Selan
0 Likes
Absent Member.
Absent Member.

We tried to configure the Role based services as you described.
We had the same problem with the "no name" entry and the not assigned driver item in the page list. But after assiging the driver item to the page list it did not stay there. After a new login (and after restarting tomcat) it appears again on the "available" list.

regards,
stefan
0 Likes
Absent Member.
Absent Member.

After a reboot the assigned page list looks fine, but the driver tab in he driverstore is still missing.

regards,
Stefan
0 Likes
Absent Member.
Absent Member.

Mare Selan;1896133 wrote:
Hi,

had the same issue...
Try this:
Go to iManager / Configure / Rolde based Services / RBS configuration
Click your RBS 2 object
Choose Property Book tab, choose Manage Driver Store, select Actions / Page
List
There you can move "Drivers" page from Available to Assigned
Logout iManager and try it out.

FYI, I have what seems to be previous version of "Drivers" page on "Assigned
pages" and they look like "No Name / iPrintX.DriverStoreXP
iPrintX.DriverStoreW200 ..."

Regs,
Mare Selan


Thank you Mare! I followed your instructions and it seems to have resolved the missing Drivers tab issue. I didn't need to restart. It worked immediately after the change. I'll have to restart the server and verify if the changes 'stick'.

Thanks again.
0 Likes
Absent Member.
Absent Member.

kiefabeb;1897492 wrote:
Thank you Mare! I followed your instructions and it seems to have resolved the missing Drivers tab issue. I didn't need to restart. It worked immediately after the change. I'll have to restart the server and verify if the changes 'stick'.

Thanks again.


We don´t see any items like "No Name / iPrintX.DriverStoreXP
iPrintX.DriverStoreW200 ..." in the available list.
So we can´t do anything as you described.

we removed the iprint plugin from imanager, rebooted the server.
we reinstalled the iprint plugin, the problem persists.

is there a way to reset the iprint plugin settings to default ?

regards,
stefan
0 Likes
Absent Member.
Absent Member.

Just wanted to say I had the same problem. I am still at oes2 sp1, picked up the upgrade from the 11/13 update. Have our first batch of Win 7 computers and have spent a full day so far trying to get iprint to work.

After adding new imanage module the drivers tab disappeared. Doing the Role Based Services has brought it back. The server is heavily used, all the time, so I'm not in a position to see if the drivers tab stays after a restart.

Craig Lyndes
St Albans City School
0 Likes
Absent Member.
Absent Member.

I also had to go through the Role Based Services to add the Drivers tab to the Manage Printers section of iPrint. Again there was the invisible, left over iPrintX.DriversXP (etc one for each OS type) under Manage Printer.

This was so I could add the Windows 7 printer driver to the printer.

Craig Lyndes
St Albans City School

clyndes;1898471 wrote:
Just wanted to say I had the same problem. I am still at oes2 sp1, picked up the upgrade from the 11/13 update. Have our first batch of Win 7 computers and have spent a full day so far trying to get iprint to work.

After adding new imanage module the drivers tab disappeared. Doing the Role Based Services has brought it back. The server is heavily used, all the time, so I'm not in a position to see if the drivers tab stays after a restart.

Craig Lyndes
St Albans City School
0 Likes
Absent Member.
Absent Member.

clyndes;1898503 wrote:
I also had to go through the Role Based Services to add the Drivers tab to the Manage Printers section of iPrint. Again there was the invisible, left over iPrintX.DriversXP (etc one for each OS type) under Manage Printer.

This was so I could add the Windows 7 printer driver to the printer.

Craig Lyndes
St Albans City School


Thank you Craig,
that solved my problem.
Adding everything (also the "invisible" ones) to the right panel (assigned) helped. Now i can see the driver tab with the recent OS Support (incl. vista and Win7)

regards,
stefan
0 Likes
Absent Member.
Absent Member.

this procedure is just not working for me -- I am on OES2 sp1 Linux and did the update for Win7 support. After that I had no "Drivers" tab in "Manage Driver Store". I follow this procedure and find the Drivers tab in the "Available" window and I move it to Assigned. When I go back to manage the driver store I have a Drivers tab but nothing else -- no choices for the various platforms -- only a "Current drivers" window with nothing in it. If I click on "Add from file" I get a "an ip address was not available" message. I have stopped and restarted both apache and tomcat but to no avail. My "iPrint Linux Management Plug-in" is 2.7.1.20090924.

But if I go to "Manage Printer" and then click my Drivers tab I see all the platforms listed in the "Drivers Platform" drop down -- including Win7 32b and 64b.

Any ideas on what I can try?

--
Wayne Fee
IT Enterprise Systems
Appalachian State University
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.