bjflinn Absent Member.
Absent Member.
5754 views

IE8 (protected) on Win 7 not printing to iPrint printers

Hello,
My setup is NW65sp8a. I cannot get IE8 (on Windows 7) to print to a successfully installed iPrint printer. All other programs will print so the problem is the IE8 protected mode. If I turn protected mode off, I can print from IE8.
I have tried adding "ipp://server" and "ipp://server/ipp/printername" to the Trusted Sites section of IE8 - doesn't help - is my syntax incorrect?
Is there anyone out there who has actually succeeded in printing to an iPrint printer with protected mode on in IE7 or IE8 on Vista or Windows 7? If so, please tell me your secret!
I had the same problem on Vista with iPrint so I abandoned it and kept installing WinXP until Windows 7 came along. Now I find exactly the same thing with Windows 7.
I would hate to resort to having my users run IE8 with protected mode off all the time.
Thanks for any help.

Bernie
0 Likes
16 Replies
seanturner83 Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

Is this eg. printing out a webpage? I added google.co.uk to the restricted sites zone, refreshed and made sure that I was in protected mode, then successfully printed a document using an iprint printer, on 7 64 bit. What pages are you trying to print? What's your settings in iprint.ini?
0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

seanturner83;1929740 wrote:
Is this eg. printing out a webpage? I added google.co.uk to the restricted sites zone, refreshed and made sure that I was in protected mode, then successfully printed a document using an iprint printer, on 7 64 bit. What pages are you trying to print? What's your settings in iprint.ini?

I am trying to print out web pages from IE8 (could be any web page of course). Now I am confused by your reply. You say that you have added google.co.uk and successfully printed a document. "Document" to me means Word, Excel or PDF, etc. Do you actually mean a document or do you mean you printed a simple web page, e.g. I like printing Google as a test as I know it will print on a single page. It doesn't really matter what web site page I print, if IE8 was cooperating, I should be able to print any web page. From other hints from the web, they suggested that I needed to add my iPrint server URL to the IE8 Trusted Sites because IE8 is trying to print to an iPrint printer which has a URL like ipp://servername/ipp/printername.

Here are my iprint.ini settings:
AllowAutoUpdate = 2
ShortInstallName = mytree
AllowUserPrinters = 1
UpgradeNDPSPrinters = 0
UpgradeQMSPrinters = 0
InformUserOfUpdates = 1

With Win7 and IE8 in protected mode, are you able to bring up any web site home page and print it? I can't so I am wondering whether it is my set up, or does everyone printing from IE8 in protected mode to an iPrint printer have this problem. I can print from any other application, e.g. Word, Excel, etc.
0 Likes
seanturner83 Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

Ah, now I understand the problem more - will take a look.
0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

Sean,
By the way, are you using any Vista or Windows 7 machines with IE7 or IE8 in protected mode? Can you actually print to an iPrint printer from IE without getting a "creation failed" error in the iPrint document status windows? I am just curious whether the majority of people with this type of environment are not having this particular IE "protected mode" issue, and therefore, there must be something strange in my Netware environment.
Since there has only been your reply, I am assuming that this problem is not wide spread. I can't seem to find much about it either by Googling or by checking on the Novell Support Site.

Bernie
0 Likes
seanturner83 Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

all of the vista and 7 machines that we are running so far are using iprint and IE8 in protected mode (although many are "power user" machines, so the first thing they do is install firefox on these, any that are machines for testing will be using IE)
0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

I have the same "IE protected mode" printing problem with a user either as "administrator" or "power user". But you didn't say whether you are printing ok from IE in protected mode. Are you? I assume you must be if you haven't had anybody complain and at least some of your users are using IE in protected mode.
0 Likes
seanturner83 Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

Sorry, you took power user in the wrong context - I mean power user like my boss and the dev team, not like someone who doesn't have admin rights - I'll test as both as I'm curious about this.
0 Likes
mhitesh Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

About an year back one customer had reported same problem on IE7. We have never been able to reproduce this problem in our environments. But here are some links which helped him resolve the issue.

http://forums.novell.com/showthread.php?t=370388

http://forums.fuzioned.com/showthread.php?t=4464

http://www.eggheadcafe.com/conversation.aspx?messageid=32524064&threadid=32524064

http://www.eggheadcafe.com/conversation.aspx?messageid=32524078&threadid=32524064

I am hoping this will help you. The problem was related to printer names for this customer but the same printers names work fine in our environments. I am still trying to figure what is it that I can do to reproduce this here.

Thanks,
-Hitesh.



>>> bjflinn<bjflinn@no-mx.forums.novell.com> 2/6/2010 6:26 AM >>>


Hello,
My setup is NW65sp8a. I cannot get IE8 (on Windows 7) to print to a
successfully installed iPrint printer. All other programs will print so
the problem is the IE8 protected mode. If I turn protected mode off, I
can print from IE8.
I have tried adding "ipp://server" and
"ipp://server/ipp/printername" to the Trusted Sites section of IE8 -
doesn't help - is my syntax incorrect?
Is there anyone out there who has actually succeeded in printing to
an iPrint printer with protected mode on in IE7 or IE8 on Vista or
Windows 7? If so, please tell me your secret!
I had the same problem on Vista with iPrint so I abandoned it and
kept installing WinXP until Windows 7 came along. Now I find exactly
the same thing with Windows 7.
I would hate to resort to having my users run IE8 with protected
mode off all the time.
Thanks for any help.

Bernie


--
bjflinn
------------------------------------------------------------------------
bjflinn's Profile: http://forums.novell.com/member.php?userid=38850
View this thread: http://forums.novell.com/showthread.php?t=400782

0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

I looked at the links you mention in your email. So I tried installing a printer with the name "lmrs" (abbreviation for my building) which has no capital letters or numbers. Still no protected mode printing.
I also removed the Sophos antivirus software (just to try since one of the links said the AVG antivirus software could cause the problem) on my Windows 7 machine and tried IE protected mode printing again - still no go!

I may try installing a clean NW6.5sp8 system and see if I get the same printing problem.
0 Likes
mhitesh Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

Do you want to try with a fresh Windows 7 machine which has no additional software installed and no changes to the security settings of IE.

I would not suspect this issue to have anything to do with the server. It should be something on the client side.

Thanks,
-Hitesh



>>> bjflinn<bjflinn@no-mx.forums.novell.com> 2/10/2010 12:56 AM >>>


I looked at the links you mention in your email. So I tried installing
a printer with the name "lmrs" (abbreviation for my building) which has
no capital letters or numbers. Still no protected mode printing.
I also removed the Sophos antivirus software (just to try since one of
the links said the AVG antivirus software could cause the problem) on my
Windows 7 machine and tried IE protected mode printing again - still no
go!

I may try installing a clean NW6.5sp8 system and see if I get the same
printing problem.


--
bjflinn
------------------------------------------------------------------------
bjflinn's Profile: http://forums.novell.com/member.php?userid=38850
View this thread: http://forums.novell.com/showthread.php?t=400782

0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

As it turns out, the Win7 machine is a fresh install with nothing but Windows updates done and the Win7 client installed and the iPrint client as well.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

On 10/02/2010 3:56 PM, bjflinn wrote:
>
> As it turns out, the Win7 machine is a fresh install with nothing but
> Windows updates done and the Win7 client installed and the iPrint client
> as well.
>
>

I discussed this issue some months ago on this forum. Most printers at
our site have this problem on Vista clients IE 7 and 8. Server is
Netware 6.5.8 Moved on to try and solve other problems. Revisiting issue
now.

I did replace one printer with lower case named printer and problem went
away. I thought I had it resolved, but I couldn't repeat the fix.

Run IE as administrator and IE pages print fine. Most of our users have
protected mode on, but may have to change this if they want to print. We
are stuck on IE because it works best with Outlook Web Access. PDFs and
DOCs inside IE will not print and need to save to print

We have over 40 printers, must test them all. I no a few give no problems.

Warrem
0 Likes
bjflinn Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

I am just getting back to this myself after a period of interruptions. I have set up a test OES2 Linux server with iPrint and am going to test whether the same Windows 7 computer will or will not be able to print in IE protected mode to an iPrint printer on the OES2 Linux server. I will post my results when finished.

Bernie

mcu;1947286 wrote:
On 10/02/2010 3:56 PM, bjflinn wrote:
>
> As it turns out, the Win7 machine is a fresh install with nothing but
> Windows updates done and the Win7 client installed and the iPrint client
> as well.
>
>

I discussed this issue some months ago on this forum. Most printers at
our site have this problem on Vista clients IE 7 and 8. Server is
Netware 6.5.8 Moved on to try and solve other problems. Revisiting issue
now.

I did replace one printer with lower case named printer and problem went
away. I thought I had it resolved, but I couldn't repeat the fix.

Run IE as administrator and IE pages print fine. Most of our users have
protected mode on, but may have to change this if they want to print. We
are stuck on IE because it works best with Outlook Web Access. PDFs and
DOCs inside IE will not print and need to save to print

We have over 40 printers, must test them all. I no a few give no problems.

Warrem
0 Likes
bjw Absent Member.
Absent Member.

Re: IE8 (protected) on Win 7 not printing to iPrint printers

bjflinn;1929105 wrote:
Hello,
My setup is NW65sp8a. I cannot get IE8 (on Windows 7) to print to a successfully installed iPrint printer. All other programs will print so the problem is the IE8 protected mode. If I turn protected mode off, I can print from IE8.
I have tried adding "ipp://server" and "ipp://server/ipp/printername" to the Trusted Sites section of IE8 - doesn't help - is my syntax incorrect?
Is there anyone out there who has actually succeeded in printing to an iPrint printer with protected mode on in IE7 or IE8 on Vista or Windows 7? If so, please tell me your secret!
I had the same problem on Vista with iPrint so I abandoned it and kept installing WinXP until Windows 7 came along. Now I find exactly the same thing with Windows 7.
I would hate to resort to having my users run IE8 with protected mode off all the time.
Thanks for any help.

Bernie
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.