Commodore
Commodore
913 views

Installing Printers with Firefox does not work any more

iPrint Client v6.20 iPrint on OES 2018 SP1

Some Windows systems can't install iPrint printers with Firefox. Windows 10 2004 and Windows 10 20H2. After installing iPrint Client this application setting for iPrint is missing in Firefox settings:

Screenshot_20201028_125323.png

My guess (!) is that whether it works or not depends on when the system or Firefox or iPrint Client was installed. It does not work on recently installed systems, but it works on older systems, even when Windows, Firefox and iPrint Client are updated to the latest versions.

Any ideas what the reason for this problem is?

Thanks,

Mirko

0 Likes
15 Replies
Micro Focus Expert
Micro Focus Expert

If i have translated properly, the screenshot shows that the option selected is "always ask".

When i've got this option and try to install a printer, firefox comes with a popup to select the application and on the top it is the iprint install one. Selecting this option and marking the checkbox to remember, it added to the application list on firefox settings and i could install printers with no problems.

So what is exactly the problem? What happen when you try to install a printer? Do you have pops blocked on the printer page?

 

I'm using windows 10 2994 build 19041.572

Firefox 82.0.1

0 Likes
Commodore
Commodore

The setting showed in the screenshot is missing. It's just not there on systems where the problem occurs, and I can't add it manually because there is no entry for Micro Focus iPrint available in the drop down list.

0 Likes
Micro Focus Expert
Micro Focus Expert

1. Can you post a screenshot from the system where it is missing?

2. What error do you get when trying to install a printer and is it the pop up appearing to select an application?

3. Which firefox version are you running?

0 Likes
Commodore
Commodore

1.Screenshot_20201028_160544.png

2. Trying to install a printer looks like this:

Screenshot_20201028_161028.png

If I enlarge the small popup window, it's just the printer selection page of iPrint:

Screenshot_20201028_161237.png

3. Firefox 82.0.2 on Windows 10 20H2 in this case, but the same happened with Firefox 81.? on Windows 10 2004

Screenshot_20201028_161519.png

 

Here is a screenshot from a system where iPrint printer installation works all right:

Screenshot_20201028_162003.png

0 Likes
Micro Focus Expert
Micro Focus Expert

Did you try to reinstall the iprint client 6.20?

 

i'll try to duplicate in my lab

0 Likes
Micro Focus Expert
Micro Focus Expert

@mguldner 

Could you please log a support case?

Thanks

Tarik

0 Likes
Commodore
Commodore

Yes, I tried reinstall of the iPrint client; also reinstalled Firefox and then iPrint client.
0 Likes
Commodore
Commodore

OK, done. SR #101313019121

Thanks,
Mirko
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

@gmorera 

I see two legacy Bugzilla bugs regarding this (1173609 & 1173551). Did me make any progress regarding these?

 

If you like it: like it.
0 Likes
Micro Focus Expert
Micro Focus Expert

Hi Mathias:

- bug 1173551:

This is a browser behavior, change it on latest versions to disable by default
the launch of a helper in non https pages. There is a policy to enable it again:

To allow http as well, you need to create a new windows registry or Group Policy
(ADMX). I've tested with a windows registry and it worked fine for both Edge and Chrome, no more pop ups. This is the entry for Edge:

https://docs.microsoft.com/en-us/deployedge/microsoft-edge-
policies#autolaunchprotocolsfromorigins


Path (Mandatory): SOFTWARE\Policies\Microsoft\Edge

Path (Recommended): N/A

Value Name: AutoLaunchProtocolsFromOrigins

Value Type: REG_SZ

 

Enter this data:

[{"allowed_origins": ["*"], "protocol": "iprint"}]

I've passed the info to Micro Focus support and they're writing some tids
about  it. They will be released soon.

Thanks

Gonzalo

Micro Focus Expert
Micro Focus Expert

- bug 1173609:

Micro focus still working on it. There is a workaround to add the missing info manually in the handlers.json.

handlers.json working:

{"defaultHandlersVersion":{"en-US":4},"mimeTypes":{},"schemes":{"irc":
{"stubEntry":true,"handlers":[null,{"name":"Mibbit","uriTemplate":"https://
www.mibbit.com/?url=%s"}]},"ircs":{"stubEntry":true,"handlers":[null,{"name":
"Mibbit","uriTemplate":"https://www.mibbit.com/?url=%s"}]},"mailto":
{"stubEntry":true,"handlers":[null,{"name":"Yahoo!
Mail","uriTemplate":"https://compose.mail.yahoo.com/?To=%s"},{"name":"Gmail",
"uriTemplate":"https://mail.google.com/mail/?extsrc=mailto&url=%s"}]},
"iprint":{"action":4}}}

 

 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.