Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Admiral
Admiral
1522 views

Iprint 4 appliance external directory

I have an issue adding an external auth directory on Print 4 appliance. All updates installed. The strange part is it appears to work but no external auth servers show up. I have tried both AD and Edir. It accepts the info and appears to work but never shows up in the list. So no external auth. I have searched the system everywhere and can find nothing in any log anywhere. I don't really want to blow it away and start over at this point. Anyone seen this before and have any idea what logs contain the info to figure out why it is doing it? Need an external directory. Don't want to have to put users on the appliance.

0 Likes
12 Replies
Captain
Captain

When you set up the Directory Services, you have to enter the path information for the domain plus add the user paths.  So we use AD for both users and printer groups.  Under Server Information, we filled out the LDAP Server URL info, User DN, Password, Directory Type: Active Directory and Account Name Attribute is sAMAccountNAME but that part is not where we were able to import users.  The user import didn't come until we did the Users\Groups associations.  On Base DN, we entered the OU information to point where the users reside in AD, and used this filter: (&(!(objectClass=computer))(|(objectClass=Person)(objectClass=orgPerson)(objectClass=inetOrgPerson)))
You also have to be sure to click "Search Subtree" to capture any users in any subgroups. Because we (admin group) are separate we added that group as well. Since we use AD to house groups for printers (so users can be associated to printers by desktop support), we also added that group.  Hope that helps.

0 Likes
Admiral
Admiral

I have done it exactly what you said. It always finishes as though it worked. Even tried testing with wrong user info, and that errors at it should. I think I am going to have to blow it away and start over. I have a 3.2 version that works fine. No I don't want to migrate it to 4. I built it clean so I know no straggling issues from previous upgrades. 

0 Likes
Captain
Captain

that might work well.  I can say I've had more issues since upgrading to v4.0 and the patch didn't help either.  the documentation on upgrading is grossly missing content.  I currently have to launch IE as admin (never had to do this in the old version) and use the IP address instead of DNS name just to get the admin console where I can create printer profiles.  I also a variety of issues with iPrint since migrating up.  I'm currently researching another product altogether because I think my time with the iPrint is nearing the end.

0 Likes
Micro Focus Expert
Micro Focus Expert

1. Did you try with different browsers?

2. Is it ldaps or ldap connection to the AD server?

3. If it is ldaps, did you import the root cert?

 

iprint_auth.log will show if there is a sync with the ldap server and datamodel log if there is an error during configuration

The problem with IE reported by the other user is if IE has compatibility mode enable, just disable it or if it is configured with a proxy, just remove it. You'll have similar issues accessing iManager in OES if one or both of this conditions exist.. My IE works with no problem with the appliance

Actually you only need IE to create printer profiles, for all other tasks you can use chrome or firefox. Micro focus is working on priority to build a browser independent platform to perform all operations and remove this little dependency in IE.

4.1 is a very stable and robust platform so if you're having other issues, feel free to mention them, we'll try to help

 

0 Likes
Admiral
Admiral

Thank you for your comment. I just can't believe what the solution was. Seems to be an issue with firefox on the mac. Have not tried widows yet. Chrome and Safari display it just fine. It even crossed my mind to try a different browser. Funny did not see this issue with 3.2.x. Have always used FF to manage Micro Focus products. Live and learn. Just so you know there was a long list of servers when I tried the different browser. I had to delete a lot of them. So  FF was creating them. Just never displaying them.

 

If someone else can try it on a mac and has backend access and dupe it with 4.x and FF I would like to hear.

 

Thanks

0 Likes
Captain
Captain

The interesting thing is that we already run IE in compatibility mode, but the issues persist.  One issue since upgrading to v4 is if I open a profile to check settings, I can do so but when I get to the end it takes about 2-3 minutes before it unfreezes and tries to go back to the profile page.  If I review or create more than 2 profiles, the entire browser experience simply faults.  Then I lose access to the iPrint appliance all together via IE, but can open in Chrome.  However, you can not use Chrome, Edge, or Firefox to create profiles.  I usually have to switch to my other pc to continue before the issue repeats itself.  I've worked with support on all of these issues and they are still present.

0 Likes
Micro Focus Expert
Micro Focus Expert

you have to disable compatibility mode and remove any proxy settings. Most of the IE issues are related to this two.

Also remove any IE add-ons.

When you edit a profile, everything is happening on the PC so make sure you're using iprint client 6.20 and if you have any antivirus or internet suite like McAffe, remove them to test  it.

If the driver in the profile you're editing is a bi-directional driver,  the pc will try to contact the printer to gather the info. If it is not reachable, it may take sometime to give control back.

On my 4.1 appliance , i could not duplicate this issue so it may be a very specific one on your setup

0 Likes
Micro Focus Expert
Micro Focus Expert

Do you mind sharing the SR numbers?
If there is no closure to these issues, we need to prioritize them properly with engineering.

Thanks
Tarik
Captain
Captain

that would be great, here are the past most recent SR's submitted: 

SR#101301166381
SR#101301166483
SR#101300329481
SR#101301166449
SR#101301166415

 

0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Hi kjohnson8,

I have looked into each SR.  Here is my summary of where each are at.  Let me know if your understanding  differs from mine:

101301166381 - Can't access iManager from IE.
The iPrint team is working on a solution to this by creating a non-IE dependent tool to create printer driver profiles and to upload printer drivers.

101301166483 - IE not detecting iPrint Client
I'll follow-up with the SR owner for this one.

101300329481 - iPrint iCM Not Syncing to Active Directory
I believe you found a workaround of removing the OES Client.

101301166449 - Printer Driver Profile settings takes long time in IE.
This will also be resolved with the non-IE based tool.

101301166415 - IE not auto-detecting the Windows OS.
This will also be resolved with the non-IE based tool.

Admiral
Admiral

I must say it is about time that this is being decoupled from IE. That has been a dead browser for so long.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.