Highlighted
Absent Member.
Absent Member.
1068 views

Macintosh Iprint Issue

I must be missing something.. We have Iprint installed on SLES 11 SP3 (OES SP2). It has been working perfectly for our windows users for years.. We are now trying to roll it out to the macintosh people to use.. I have uploaded the PPD files to the driver store for the macintosh, assigned it to the printers.. open up the url/ipp and double click on the printer and it comes back saying it was successfully added.. We go to to print to the printer it acts like it printed but never comes out on the printer. printing to the printer via bonjour works fine..printing to the printer via a windows computer also works fine.
The windows computers are all authenticated to the tree when then they go to print...How do I get the iprint client to request authentication to the tree before they are permitted to print..??...We have the printer user access set in imanager to allow all users in the context, but Im thinking the mac is never asking for or sending the user credentials to the iprint server to determine if he/she is permitted to print to this device..Any help would be greatly appreciated from anyone currently using iprint on macintosh computers.
Thanks in advance
Doug
0 Likes
2 Replies
Highlighted
Absent Member.
Absent Member.

Re: Macintosh Iprint Issue

actually I just tested on a windows computer again.. if I check the box on the print printer to "enable secure printing" I get a internal server error when trying to install the printer on a windows device.. the windows workstation has the novell client installed... does this help anyone who may have a suggestion ??/... works fine on same windows computer as long as "enable secure print" is NOT checked
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: Macintosh Iprint Issue

You have to have secure printing enabled for the Mac iPrint client to work properly. I'm not sure why its not working on your windows workstations without some more information. We have this working in all of our labs and for student workstations and don't have this issue. The secure printing setting is required for all the student devices we have as well because they do not have the Novell Client installed.

Are you deploying iPrint printers to Windows through ZENWorks policies?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.