Anonymous_User Absent Member.
Absent Member.
2345 views

NDPS Broker RMS error

Hi All,

Netware 6.5 SP4a
I have noticed that I cant upload a new driver to a printer object in
iManager.
From iManager if I select the Manage Broker, then select Resource Managent
Service I get a msg saying:
'Exception reading resource print drivers configuration
The resource management service (RMS) is diabled'


When I load the Broker at the console or try to enable RMS from the Broker,
error msg is returned:

'The BROKER could not enable the Resource Management Service. Error
code -613'

also the following msg is displayed,

' [date time] The RMS could not generate a database path either because the
broker object does not have rights to read it's own attributes, or because
attributes are missing. Error code -603. Use netware administrator to assign
rights to the broker object or create a new broker object.'


It has been working fine for the last year, I have not chaged anything
recently on the server, except for! last weekend I upgraded the server to
SP4a but this problem was present even before the upgrade.


Any help or tips welcome.

TIA
Daniel






0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: NDPS Broker RMS error

A 613 error is a syntax violation for eDirectory attribute. Sounds like
there are some eDirectory issues. Basically when you load the broker, and
subsequently the RMS, there is logic in place to read the attribute on the
broker object to figure out where the driver file structure is. (server and
volume, etc). It is complaining that these attributes are bad...

>>> On 1/16/2006 at 8:05 am, in message

<hDOyf.118$Pa2.113@prv-forum2.provo.novell.com>, Daniel
Richards<drc@leighctc.kent.sch.uk> wrote:
> Hi All,
>
> Netware 6.5 SP4a
> I have noticed that I cant upload a new driver to a printer object in
> iManager.
> From iManager if I select the Manage Broker, then select Resource
> Managent
> Service I get a msg saying:
> 'Exception reading resource print drivers configuration
> The resource management service (RMS) is diabled'
>
>
> When I load the Broker at the console or try to enable RMS from the
> Broker,
> error msg is returned:
>
> 'The BROKER could not enable the Resource Management Service. Error
> code -613'
>
> also the following msg is displayed,
>
> ' [date time] The RMS could not generate a database path either because
> the
> broker object does not have rights to read it's own attributes, or
> because
> attributes are missing. Error code -603. Use netware administrator to
> assign
> rights to the broker object or create a new broker object.'
>
>
> It has been working fine for the last year, I have not chaged anything
> recently on the server, except for! last weekend I upgraded the server
> to
> SP4a but this problem was present even before the upgrade.
>
>
> Any help or tips welcome.
>
> TIA
> Daniel

0 Likes
Highlighted
Anonymous_User Absent Member.
Absent Member.

Re: NDPS Broker RMS error

OK, makes sense.

How would one start to find the bad attributes?

I supose I could delete the Broker and re-create it, but I have PCounter
auditing the printers/jobs/broker/prnt_mngr etc, and I wanted to avoid
having to re-configure the PCounter to monitor the broker.



NOTE:
after the broker is loaded it returns two errors:
613
603

Any other tips welcomed 😉

TIA
Daniel


"iprintrox" <iprintrox@iprint.novell.com> wrote in message
news:43CCB67A.E03D.00DE.0@iprint.novell.com...
> A 613 error is a syntax violation for eDirectory attribute. Sounds like
> there are some eDirectory issues. Basically when you load the broker,

and
> subsequently the RMS, there is logic in place to read the attribute on the
> broker object to figure out where the driver file structure is. (server

and
> volume, etc). It is complaining that these attributes are bad...
>
> >>> On 1/16/2006 at 8:05 am, in message

> <hDOyf.118$Pa2.113@prv-forum2.provo.novell.com>, Daniel
> Richards<drc@leighctc.kent.sch.uk> wrote:
> > Hi All,
> >
> > Netware 6.5 SP4a
> > I have noticed that I cant upload a new driver to a printer object in
> > iManager.
> > From iManager if I select the Manage Broker, then select Resource
> > Managent
> > Service I get a msg saying:
> > 'Exception reading resource print drivers configuration
> > The resource management service (RMS) is diabled'
> >
> >
> > When I load the Broker at the console or try to enable RMS from the
> > Broker,
> > error msg is returned:
> >
> > 'The BROKER could not enable the Resource Management Service. Error
> > code -613'
> >
> > also the following msg is displayed,
> >
> > ' [date time] The RMS could not generate a database path either because
> > the
> > broker object does not have rights to read it's own attributes, or
> > because
> > attributes are missing. Error code -603. Use netware administrator to
> > assign
> > rights to the broker object or create a new broker object.'
> >
> >
> > It has been working fine for the last year, I have not chaged anything
> > recently on the server, except for! last weekend I upgraded the server
> > to
> > SP4a but this problem was present even before the upgrade.
> >
> >
> > Any help or tips welcome.
> >
> > TIA
> > Daniel



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.