Highlighted
Absent Member.
Absent Member.
1936 views

NSCU iPrint migration LDAP error.

Hello there,

I am trying to migrate an iPrint printer agent from a Netware 6.5 SP6 server to a OES1 SP2 Linux server using the Netware Server Consolidation Utility. The migration appears to go o.k but the error log has the following message.

iPrint Message : Unable to create printer 'DPg_C_test', error code -1(general error (Binding to LDAP failed))

Any ideas as to what may be causing this error?

Regards,

Seamus.
Tags (4)
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

donohos,

> iPrint Message : Unable to create printer 'DPg_C_test', error code
> -1(general error (Binding to LDAP failed))


The error message seems to indicate an LDAP problem. Is the LDAP server on
your NetWare and OES server working properly? You can test using an LDAP
Browser by verifying access to LDAP and LDAPS as both anonymous and an
authenticated user.


--
_________________________________________
Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

Niclas Ekstedt Sr Consultant Atea Sverige AB
0 Likes
Highlighted
Absent Member.
Absent Member.

I can log onto the server using my eDir username and password. Does this mean LDAP authentication is working o.k?
I have been out on holidays, hence the delay in responding.

Thanks,

Seamus.
0 Likes
Highlighted
Absent Member.
Absent Member.

donohos,

>
> I can log onto the server using my eDir username and password. Does this
> mean LDAP authentication is working o.k?


Nope not necessarily. First of all it depends on if the client you use fro
the login is actually using LDAP or not. And even if it does, it will
probably just use one LDAP method for the login.

To be perfectly sureyour LDAP in in order, you need to test it using an LDAP
browser. Check out Novell Support TID 10075010 for more info.


--
_________________________________________
Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

Niclas Ekstedt Sr Consultant Atea Sverige AB
0 Likes
Highlighted
Absent Member.
Absent Member.

Hello Niclas,

I tested LDAP using the utility you recommended. I could connect anonymously but not as an authenticated user on port 389.
When I tried either anonymous or authenticated on port 636 I get the error below.

15:19:45: Failed to connect to ldap://10.244.36.201:636
Reason: 10.244.36.201:636; socket closed

I appreciate your help with this.

Regards,

Seamus.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.