Anonymous_User Absent Member.
Absent Member.
2716 views

Printer Drivers will not load into broker with iManager.

Hi all.

The iManager driver uploads into the broker no longer functions.

I have reordered the search path so SEARCH ADD SYS:\JAVA\NJCLV2\BIN is
before SEARCH ADD SYS:\ni\update\bin. IPX is not enabled. The remote
manager through HTTPSTK port 8009 functions.

The certificates were recreated then verified with PKDIAG, and re-
imported with TCKEYGEN without error.

I have uninstalled iManager 2.0.2 on one server then installed iManager
2.6 without success. I have install iManager 2.6 over top iManager 2.0.2
on another server without success.

I have tried TID 10100923 fix/iManager plug-in patch.

The user account is authorized in the iManager Server Configuration.

So far nothing has resolved the driver upload failure through iManager.

The process appears to fail after the files leave the local workstation
NDPS/DRV_TMP folder and are transferred from the NDPS\XFER folder to the
\NDPS\resdir\ENGLISH\Prndrv\XXX.

The error message IE displays,
"Internal error : A page has performed an illegal operation."

The last line of the logger console screen displays,
"Propertybook........1528 java.lang.NullPointerException."

The servers are running Netware 6.5 SP5 with post patches for NIPPED,
NDPSM, TSA, NWFTP, eDir 8.7.3.8. The driver upload was functional prior
to SP5 roll out.

Any ideas would be appreciated. Right now the only way I can upload
drivers is with NWAdmin.

As a note, I have built a production server and a test server in
standalone trees with Netware 6.5 SP5 overlay, Post SP5 patches, and
iManager 2.5/2.6 where the iManager Broker printer driver upload
functions correctly. This tends to point to a prior version/configuration
issue in the existing tree's servers. Where is the question?

Thank you.
Jeff

0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Printer Drivers will not load into broker with iManager.

Based on some of your information it would appear that you are running with
an iPrint/ iManager combo that utilizes HTTPSTK to upload the driver.
Indicating that the driver file gets copied to the ndps\xfer directory is
the clue! This indicates the old HTTPSTK method is being used. On a NW65
sp5 the HTTPSTK method should not even be used, if running a valid version
of iManager and the shipping iPrint Client. This really does sound like
an iManager configuration problem.. You indicate that NWAdmin uploads
fine. The iManager iPrint Plugin that shipped with NW6.5 sp5 utilizes the
same mechanism to upload drivers and NWAdmin does. So it must be an
iManager configuration...

What iPrint Plugin is installed?? What iPrint Client are you running
with?? Have you "pinged" the iManager forum??

>>> On 5/9/2006 at 10:26 AM, in message

<mp38g.3806$U_.3767@prv-forum2.provo.novell.com>, <jeffmeldrum@sd28.bc.ca>
wrote:
> Hi all.
>
> The iManager driver uploads into the broker no longer functions.
>
> I have reordered the search path so SEARCH ADD SYS:\JAVA\NJCLV2\BIN is
> before SEARCH ADD SYS:\ni\update\bin. IPX is not enabled. The remote
> manager through HTTPSTK port 8009 functions.
>
> The certificates were recreated then verified with PKDIAG, and re-
> imported with TCKEYGEN without error.
>
> I have uninstalled iManager 2.0.2 on one server then installed iManager
> 2.6 without success. I have install iManager 2.6 over top iManager 2.0.2
>
> on another server without success.
>
> I have tried TID 10100923 fix/iManager plug-in patch.
>
> The user account is authorized in the iManager Server Configuration.
>
> So far nothing has resolved the driver upload failure through iManager.
>
> The process appears to fail after the files leave the local workstation
> NDPS/DRV_TMP folder and are transferred from the NDPS\XFER folder to the
>
> \NDPS\resdir\ENGLISH\Prndrv\XXX.
>
> The error message IE displays,
> "Internal error : A page has performed an illegal operation."
>
> The last line of the logger console screen displays,
> "Propertybook........1528 java.lang.NullPointerException."
>
> The servers are running Netware 6.5 SP5 with post patches for NIPPED,
> NDPSM, TSA, NWFTP, eDir 8.7.3.8. The driver upload was functional prior
> to SP5 roll out.
>
> Any ideas would be appreciated. Right now the only way I can upload
> drivers is with NWAdmin.
>
> As a note, I have built a production server and a test server in
> standalone trees with Netware 6.5 SP5 overlay, Post SP5 patches, and
> iManager 2.5/2.6 where the iManager Broker printer driver upload
> functions correctly. This tends to point to a prior
> version/configuration
> issue in the existing tree's servers. Where is the question?
>
> Thank you.
> Jeff

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Printer Drivers will not load into broker with iManager.

On one of the servers, I have uninstalled Apache, Tomcat, iManager (TID
10097544), deleting the Apache, Apache2, Tomcat folders. Once what I
believe to be all traces of the old iManager were removed, I installed
Apache, Tomcat, iManager from SP5 Product overlay CD, patched the Post
SP5 fixes, updated iManager to v2.6 with the latest plugins from Novell
web site (iPrint module version 2.0.3.20060418). I no longer see the
drivers going through the XFer folder. The iManager Print Driver upload
into the Broker still fails with the same errors.
The error message IE displays,
"Internal error : A page has performed an illegal operation."
The last line of the logger console screen displays,
"Propertybook........1528 java.lang.NullPointerException."
Thanks, Jeff.


> Based on some of your information it would appear that you are running
> with an iPrint/ iManager combo that utilizes HTTPSTK to upload the
> driver. Indicating that the driver file gets copied to the ndps\xfer
> directory is the clue! This indicates the old HTTPSTK method is being
> used. On a NW65 sp5 the HTTPSTK method should not even be used, if
> running a valid version of iManager and the shipping iPrint client.
> This really does sound like an iManager configuration problem.. You
> indicate that NWAdmin uploads fine. The iManager iPrint Plugin that
> shipped with NW6.5 sp5 utilizes the same mechanism to upload drivers
> and NWAdmin does. So it must be an iManager configuration...
>
> What iPrint Plugin is installed?? What iPrint Client are you running
> with?? Have you "pinged" the iManager forum??
>
> >>> On 5/9/2006 at 10:26 AM, in message

> <mp38g.3806$U_.3767@prv-forum2.provo.novell.com>,
> <jeffmeldrum@sd28.bc.ca>
> wrote:
> > Hi all.
> >
> > The iManager driver uploads into the broker no longer functions.
> > I have reordered the search path so SEARCH ADD SYS:\JAVA\NJCLV2\BIN
> > is before SEARCH ADD SYS:\ni\update\bin. IPX is not enabled. The
> > remote manager through HTTPSTK port 8009 functions.
> > The certificates were recreated then verified with PKDIAG, and re-
> > imported with TCKEYGEN without error.
> > I have uninstalled iManager 2.0.2 on one server then installed
> > iManager 2.6 without success. I have install iManager 2.6 over top
> > iManager 2.0.2 on another server without success.
> > I have tried TID 10100923 fix/iManager plug-in patch.
> > The user account is authorized in the iManager Server Configuration.
> > So far nothing has resolved the driver upload failure through
> > iManager.
> > The process appears to fail after the files leave the local
> > workstation NDPS/DRV_TMP folder and are transferred from the
> > NDPS\XFER folder to the \NDPS\resdir\ENGLISH\Prndrv\XXX.
> > The error message IE displays,
> > "Internal error : A page has performed an illegal operation."
> > The last line of the logger console screen displays,
> > "Propertybook........1528 java.lang.NullPointerException."
> > The servers are running Netware 6.5 SP5 with post patches for NIPPED,
> > NDPSM, TSA, NWFTP, eDir 8.7.3.8. The driver upload was functional
> > prior to SP5 roll out.
> > Any ideas would be appreciated. Right now the only way I can upload
> > drivers is with NWAdmin.
> > As a note, I have built a production server and a test server in
> > standalone trees with Netware 6.5 SP5 overlay, Post SP5 patches, and
> > iManager 2.5/2.6 where the iManager Broker printer driver upload
> > functions correctly. This tends to point to a prior
> > version/configuration
> > issue in the existing tree's servers. Where is the question?
> > Thank you.
> > Jeff


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Printer Drivers will not load into broker with iManager.

The "iprntnw65sp5c.exe" patch released May 16, 2006 applied to the server
with the Apache, tomcat, iManager uninstalled then installed from SP5
overlay CD with the previous post sp5 patches has that one iManager able
to upload drivers into the Broker/s. The IPPSRVR.NLM v4.00.06.18 October
2005 in the patch appeared to be the answer. The NIPPED.NLM and NDSPM.NLM
were the same as a previous post sp5 patches. It did not fix the others
though. Hmmm the ripping out apache, tomcat ... then installing on all
the servers is not a pleasant thought. Unless anyone has an idea ...
Thanks, Jeff.

> On one of the servers, I have uninstalled Apache, Tomcat, iManager (TID
> 10097544), deleting the Apache, Apache2, Tomcat folders. Once what I
> believe to be all traces of the old iManager were removed, I installed
> Apache, Tomcat, iManager from SP5 Product overlay CD, patched the Post
> SP5 fixes, updated iManager to v2.6 with the latest plugins from Novell
> web site (iPrint module version 2.0.3.20060418). I no longer see the
> drivers going through the XFer folder. The iManager Print Driver upload
> into the Broker still fails with the same errors.
> The error message IE displays,
> "Internal error : A page has performed an illegal operation."
> The last line of the logger console screen displays,
> "Propertybook........1528 java.lang.NullPointerException."
> Thanks, Jeff.
>
>
> > Based on some of your information it would appear that you are running
> > with an iPrint/ iManager combo that utilizes HTTPSTK to upload the
> > driver. Indicating that the driver file gets copied to the ndps\xfer
> > directory is the clue! This indicates the old HTTPSTK method is

being
> > used. On a NW65 sp5 the HTTPSTK method should not even be used, if
> > running a valid version of iManager and the shipping iPrint client.
> > This really does sound like an iManager configuration problem.. You
> > indicate that NWAdmin uploads fine. The iManager iPrint Plugin that
> > shipped with NW6.5 sp5 utilizes the same mechanism to upload drivers
> > and NWAdmin does. So it must be an iManager configuration...
> >
> > What iPrint Plugin is installed?? What iPrint Client are you running
> > with?? Have you "pinged" the iManager forum??
> >
> > >>> On 5/9/2006 at 10:26 AM, in message

> > <mp38g.3806$U_.3767@prv-forum2.provo.novell.com>,
> > <jeffmeldrum@sd28.bc.ca>
> > wrote:
> > > Hi all.
> > >
> > > The iManager driver uploads into the broker no longer functions.
> > > I have reordered the search path so SEARCH ADD SYS:\JAVA\NJCLV2\BIN
> > > is before SEARCH ADD SYS:\ni\update\bin. IPX is not enabled. The
> > > remote manager through HTTPSTK port 8009 functions.
> > > The certificates were recreated then verified with PKDIAG, and re-
> > > imported with TCKEYGEN without error.
> > > I have uninstalled iManager 2.0.2 on one server then installed
> > > iManager 2.6 without success. I have install iManager 2.6 over top
> > > iManager 2.0.2 on another server without success.
> > > I have tried TID 10100923 fix/iManager plug-in patch.
> > > The user account is authorized in the iManager Server Configuration.
> > > So far nothing has resolved the driver upload failure through
> > > iManager.
> > > The process appears to fail after the files leave the local
> > > workstation NDPS/DRV_TMP folder and are transferred from the
> > > NDPS\XFER folder to the \NDPS\resdir\ENGLISH\Prndrv\XXX.
> > > The error message IE displays,
> > > "Internal error : A page has performed an illegal operation."
> > > The last line of the logger console screen displays,
> > > "Propertybook........1528 java.lang.NullPointerException."
> > > The servers are running Netware 6.5 SP5 with post patches for

NIPPED,
> > > NDPSM, TSA, NWFTP, eDir 8.7.3.8. The driver upload was functional
> > > prior to SP5 roll out.
> > > Any ideas would be appreciated. Right now the only way I can upload
> > > drivers is with NWAdmin.
> > > As a note, I have built a production server and a test server in
> > > standalone trees with Netware 6.5 SP5 overlay, Post SP5 patches,

and
> > > iManager 2.5/2.6 where the iManager Broker printer driver upload
> > > functions correctly. This tends to point to a prior
> > > version/configuration
> > > issue in the existing tree's servers. Where is the question?
> > > Thank you.
> > > Jeff

>


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.