UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
2354 views

Restricting user from printing

I just up iprint on our network. I have added one printer, and it seems
to work. I would like to restrict students from printing to this
printer. In imanager I went to Manage printer, under Access control -
User Role, I removed the container object, and just added the groups I
want to be able to use the printer. It appears that everyone can still
print to the printer. Am I missing something?

Thanks,

Dave
0 Likes
8 Replies
Absent Member.
Absent Member.

,
> I removed the container object, and just added the groups I
> want to be able to use the printer. It appears that everyone can still
> print to the printer. Am I missing something?
>

What have you set your printer security to? See:

http://www.novell.com/documentation/nw65/iprint/data/akujjgs.html

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

Security is set to medium.

>>> On 10/16/2006 at 9:54 am, in message

<VA.00001fd6.0048675d@nomail.to.me>,
Anders Gustafsson<dalton@nomail.to.me> wrote:
> ,
>> I removed the container object, and just added the groups I
>> want to be able to use the printer. It appears that everyone can still
>> print to the printer. Am I missing something?
>>

> What have you set your printer security to? See:
>
> http://www.novell.com/documentation/nw65/iprint/data/akujjgs.html
>
> - Anders Gustafsson, Engineer, CNE6, ASE
> NSC Volunteer Sysop
> Pedago, The Aaland Islands (N60 E20)
>
> Novell does not monitor these forums officially.
> Enhancement requests for all Novell products may be made at
> http://support.novell.com/enhancement
>
> Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

David Speckeen,
> Security is set to medium.
>

Try setting it to high.

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

I switched the security to high, now it asks for a username and password,
and cannot authenticate to the printer. No username or password will work.
I switched the security back to medium, then to low and it is still asking
for a username and password.

Dave

>>> On 10/16/2006 at 12:57 pm, in message

<VA.00001fdd.00f05e39@nomail.to.me>,
Anders Gustafsson<dalton@nomail.to.me> wrote:
> David Speckeen,
>> Security is set to medium.
>>

> Try setting it to high.
>
> - Anders Gustafsson, Engineer, CNE6, ASE
> NSC Volunteer Sysop
> Pedago, The Aaland Islands (N60 E20)
>
> Novell does not monitor these forums officially.
> Enhancement requests for all Novell products may be made at
> http://support.novell.com/enhancement
>
> Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

David Speckeen,
> I switched the security to high, now it asks for a username and password,
> and cannot authenticate to the printer. No username or password will work.
> I switched the security back to medium, then to low and it is still asking
> for a username and password.
>

Hm.. What version of NetWare/OES? What service packs? What version of the
iPrint client and Novell client please?

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

David Speckeen wrote:
> I switched the security to high, now it asks for a username and password,
> and cannot authenticate to the printer. No username or password will work.
> I switched the security back to medium, then to low and it is still asking
> for a username and password.


Setting security level to high switches on SSL-encryption (in imanager
client support-tab) which in turn asks for authentication. You have to
turn it off manually if you lower your security level.

Medium security level acts as all users having "user" rights to printer
without any real access control. If you want access control you have to
have high security level.

Novell client version 4.91 (4.90?) and newer and iPrint client version
4.16 (4.20 is newest) integrate authentication so that credentials that
are passed to Novell client are also used for printer authentication.
This should make authentication invisible.

Note that iPrint client uses LDAP authentication and if your users lack
UniqueID -attribute (users that have been made with nwadmin32) then
authentication might fail. There are more quirks with LDAP and I'm not
any guru that knows anything about internal mechanisms of iPrint so I
leave this to other.

Timo Pietilä
0 Likes
Absent Member.
Absent Member.

We are currently running netware 6.5 sp5 with client 4.91 sp2. Iprint
client is v4.20.00.

Is there something that needs to be set for LDAP to authenticate properly?

>>> On 10/17/2006 at 12:46 am, in message

<VA.00001fe3.0015f798@nomail.to.me>,
Anders Gustafsson<dalton@nomail.to.me> wrote:
> David Speckeen,
>> I switched the security to high, now it asks for a username and

> password,
>> and cannot authenticate to the printer. No username or password will

> work.
>> I switched the security back to medium, then to low and it is still

> asking
>> for a username and password.
>>

> Hm.. What version of NetWare/OES? What service packs? What version of
> the
> iPrint client and Novell client please?
>
> - Anders Gustafsson, Engineer, CNE6, ASE
> NSC Volunteer Sysop
> Pedago, The Aaland Islands (N60 E20)
>
> Novell does not monitor these forums officially.
> Enhancement requests for all Novell products may be made at
> http://support.novell.com/enhancement
>
> Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
Absent Member.
Absent Member.

David Speckeen,
> Is there something that needs to be set for LDAP to authenticate properly?
>

See the comment from Timo below.

- Anders Gustafsson, Engineer, CNE6, ASE
NSC Volunteer Sysop
Pedago, The Aaland Islands (N60 E20)

Novell does not monitor these forums officially.
Enhancement requests for all Novell products may be made at
http://support.novell.com/enhancement

Using VA 5.51 build 315 on Windows 2000 build 2195

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.