Anonymous_User Absent Member.
Absent Member.
2200 views

User printer only prints on computer on which it was installed

I have iPrint installed on all our Citrix servers. When a user installs a
printer, logs off and then logs on at another server the iPrint printer
won't print. When I try to print a test page I get this error:
"Test page failed to print. Would you like to view the print troubleshooter
for assistance? Operation could not be completed."
On some servers it will work, but I can't find any difference between them.

I'm using Windows 2000 SP4, Citrix Metaframe XP 1.0 FR3 SP4 and iPrint 4.12


TIA

Chris.



0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: User printer only prints on computer on which it was installed

I assume that by "log onto another server" you mean a different Citrix
server??? Is the iprint client installed on both citrix servers??

The printer is definitely in the user hive, it sounds like it just can't
communicate?? What happens if you re-install the printer when logged into
the "other server"??

>>> On 1/15/2006 at 5:36 am, in message

<wlryf.162$En3.153@prv-forum2.provo.novell.com>,
Chris<cdot.butterat@bjaadot.nl> wrote:
> I have iPrint installed on all our Citrix servers. When a user installs a
> printer, logs off and then logs on at another server the iPrint printer
> won't print. When I try to print a test page I get this error:
> "Test page failed to print. Would you like to view the print
> troubleshooter
> for assistance? Operation could not be completed."
> On some servers it will work, but I can't find any difference between
> them.
>
> I'm using Windows 2000 SP4, Citrix Metaframe XP 1.0 FR3 SP4 and iPrint
> 4.12
>
>
> TIA
>
> Chris.

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: User printer only prints on computer on which it was installed

Thanx for answering, I'm really on a dead end on this one.

"iprintrox" <iprintrox@iprint.novell.com> wrote in message
news:43CCB87D.E03D.00DE.0@iprint.novell.com...
>I assume that by "log onto another server" you mean a different Citrix
> server??? Is the iprint client installed on both citrix servers??


Yes, I mean logging on to another Citrix server. I've installed iPrint 4.12
on all Citrix servers. I've deleted all print drivers on all Citrix servers
and downloaded & installed new drivers on all Citrix servers and I uploaded
them to the print server via iManager.

>
> The printer is definitely in the user hive, it sounds like it just can't
> communicate?? What happens if you re-install the printer when logged into
> the "other server"??
>


I've checked the registry, the printer is there. Roaming profiles work like
they should.
When I install the printer on the 'other server' it works perfectly. On a
few others Citrix servers it works ok too. I've done a few tests, I'll try
to explain by using an example:

There's 5 Citrix servers and 1 Novell file & print server the user logs on
to. The Citrix servers are called CTX1, CTX2, CTX3, CTX4 & CTX5.

The user logs on to CTX1 and installs an iPrint printer. The printer works
fine. User logs off.
When the user logs in on the other Citrix servers, the printer works ok on
CTX4 on the other 3 servers it doesn't work. When the user logs on on CTX1 a
second time (after having logged on an off al other servers,) the printer
still works.

When this happened I expected the problem would be on CTX2, CTX3 & CTX5 but
I couldn't find anything wrong on them.

Then I logged on the user on CTX3, installed a Printer and printing worked
like it should. Then I logged off the user and tried the other servers. The
printer only worked on CTX2.

When I view the properties of the printer it shows ok on all servers. The
printer port looks like it should too.


>>>> On 1/15/2006 at 5:36 am, in message

> <wlryf.162$En3.153@prv-forum2.provo.novell.com>,
> Chris<cdot.butterat@bjaadot.nl> wrote:
>> I have iPrint installed on all our Citrix servers. When a user installs a
>> printer, logs off and then logs on at another server the iPrint printer
>> won't print. When I try to print a test page I get this error:
>> "Test page failed to print. Would you like to view the print
>> troubleshooter
>> for assistance? Operation could not be completed."
>> On some servers it will work, but I can't find any difference between
>> them.
>>
>> I'm using Windows 2000 SP4, Citrix Metaframe XP 1.0 FR3 SP4 and iPrint
>> 4.12
>>
>>
>> TIA
>>
>> Chris.



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.