pumpkinaz Absent Member.
Absent Member.
1122 views

Walkup Printing

I have created a walkup printer and imported users from Active directory. But when I print to the walkup printer it takes the job. But at the user portal i log in and the print job is not listed. It says no jobs.
0 Likes
3 Replies
bobjohnson Absent Member.
Absent Member.

Re: Walkup Printing

Are you printing from a mobile device? If the answer is no you can skip the rest of this post. I have seen an issue where the WalkUp printer gets created but for some reason the Secure flag doesn't get set. When this happens, you see the symptom you have described. You can check the padbtxt.xml file located in /var/opt/novell/iprint/iprint_manager.iPrintAppliance.psm directory. Find the WalkUp printer and look for the <security_enabled>1</security_enabled> setting. If it is set to 0, you can either try creating a new WalkUp printer and delete this "broken" one or you can edit this file and change the setting to 1 save the file and import the saved .XML following these instructions:
-In the console or in a putty session, unload the Print Manager by typing:
rcnovell-ipsmd stop

-Backup the Print Manager database and XML file by copying the psmdb.dat and padbtxt.xml to a safe location.
In this example, it will copy the files to /tmp. You may desire to copy to a different location:
cp /var/opt/novell/iprint/print_manager.iPrintAppliance.psm/psmdb.dat /tmp/psmdb.dat
cp /var/opt/novell/iprint/print_manager.iPrintAppliance.psm/padbtxt.xml /tmp/padbtxt.xml

-Import the padbtxt.xml with the saved change to the security setting as mentioned above
Run the following:
/opt/novell/iprint/bin/ipsmd -x /tmp/padbtxt.xml
This example assume you chose to use the padbtxt.xml saved in the /tmp directory

-Start the iPrint service
rcnovell-ipsmd start

Of course you could be seeing a completely different issue and if so, none of the above applies.
0 Likes
pumpkinaz Absent Member.
Absent Member.

Re: Walkup Printing

The print jobs are coming from the desktops. Tired the steps you sent but no dice. I am not sure if imported the users right. I am getting the users from Active Directory. The help pages did no justice. But when I was able to get the accounts synced only the last name shows up. I check all the ldap attributes.
0 Likes
bobjohnson Absent Member.
Absent Member.

Re: Walkup Printing

Yes since this is desktop printing my post would not have applied. To test if this is an issue with the imported users you could try creating a test user in iManager and assign the user a password and give the user rights to the WalkUp printer. Then test with that account. If it works, then I would assume there is an issue with the imported users.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.