Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
1138 views

Windows Print services for Unix NW 6.5 sp6

I have been using Windows Print services for Unix for years as a work around
to avoid purchasing expensive print servers and for printers that simply to
not have a print server option available to them.

All I have to do is install the Print services for unix (Add remove
programs -> Windows componenets -> Other Netowork file and Print Servies),
then add a local printer to the machine, change printer name to a "Unix" (no
spaces) then create a printer that prints to the IP of the workstation and
replace "PASSTHROUGH" with the "Unix name" of the printer.

All has been happy until I applied sp6 and post sp6 updates on Netware.

Suddenly ALL of my printers set up on machines with Windows Print services
for Unix are broken. Not completely broken, the IPrint server "sees" the
printer and machines running the IPrint client show the printer as ready and
even recieve and printed successfully popup when they send a print job to
printer. I can see the print job pass through the job list in printer
health monitor, but no print job ever comes out of the printer.

Any ideas as to what might have changed?


0 Likes
2 Replies
Absent Member.
Absent Member.

bob wrote:

>Any ideas as to what might have changed?


This is a known issue with NDPSGW.NLM from SP6. See the following page for
an explanation and for possible solutions:

http://wiki.novell.com/index.php/Nw65sp6#NDPS_gateway

--
Marcel Cox (using XanaNews 1.18.1.6)
0 Likes
Absent Member.
Absent Member.

Thanks, revved back to sp5 and all is happy once more.

Not to be peckish, but .... sheesh ... I wish there was some more pro-active
warning system about problems like this, and I in NO WAY want to denigrate
the online resources available from Novell and the work that you folks do on
the forums. However, it seems most times that in order to keep up with
potential problems I should cruise the forums, read the Wiki daily and then
of course test everything on my test network (which I plan to install some
day and then actually use at some point beyond that). Anyway...

I installed sp6 (and related updates to sp6) last Friday - good time most
folks gone for the week and I had an opening to get some things done.

I first started getting reports about not being able to print to printers
hosted through the workstation yesterday morning and spent a couple of hours
banging my head off what seemed to be the source of the problem - the host
workstation (at least it is well patched and updated now). I then worked on
duplicating the situation (another piece of time), did searches on the
forums for a solution ( more time) then posted this missive and started
wandering back through the forum and found your response to LPR
communication failed only a few days back ( hadn't thought to search on
LPR).

I then ran into the problem that I had managed to apply iprntnw65sp6a (and I
can proudly add - failed to back up the older ndpsgw.nlm file that I was
replacing) before applying the service pack so the version 5 nlm was not in
the backsp6 directory. I was saved by the fact that a colleague had a
server running IPrint that had not been patched to sp5 yet and was able to
finally get the right version of the nlm there. At least I didn't have to
build a server just to get the file.

It would be nice if a warning could be posted - in big red letters for us
attention challenged folk - as soon as a bug like this is identified, and
referencing possible problems and solutions like might be und on the WIKI.
In fact could it be possible to simply place a reference to an appropriate
location on the WIKI on the download system as a reminder to see if there
ARE any problems before you get too involved with what you have decided to
do to actually take care with the project.

Anyway thanks for the reference, and please excuse the rant. After all I
did most of it to myself.

Take care and have a good year


"Marcel Cox" <cimetmc@myrealbox.com> wrote in message
news:%_Umh.24171$jS4.17083@prv-forum2.provo.novell.com...
> bob wrote:
>
>>Any ideas as to what might have changed?

>
> This is a known issue with NDPSGW.NLM from SP6. See the following page for
> an explanation and for possible solutions:
>
> http://wiki.novell.com/index.php/Nw65sp6#NDPS_gateway
>
> --
> Marcel Cox (using XanaNews 1.18.1.6)



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.