Highlighted
Super Contributor.
Super Contributor.
2485 views

iPrint Appliance 2 and TID 7017434

Hi all,
I've been trying to setup an iPrint 2 appliance in my test network, with a view to migrating our iPrint 1.1 appliance. Everything works except for the problems described in TID 7017434 (ie no printers are listed in then Management console). I've tried the install many times, both setting up from scratch and doing a migration from 1.1 as per the documentation. I've also tried it using the same url for the print service and using a different url (as I did with our live iPrint appliance).
I get the same error in the log as describe in the TID.
I also tried installing the hot patch for iPrint2 but that just breaks the management console even more - I get HTTP error 500 java messages in the Manage Printers, Mobile and Renderer pages.

Just wondering if anyone has had the same problems and if anyone knows of a way around them? it seems odd that there's a TID abouyt this, but no discussion here about such problems!
0 Likes
12 Replies
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

imoore,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

Yes, same here. I've been trying to set up version 2.0 for several days now, always starting over from scratch, trying different approaches, but I'm always experiencing exactly the same issues you described. Even on a freshly configured appliance without any printers installed, just installing Patch 1 (.530) results in the RPC errors in the management console. I guess I'm at the point where I need to raise an SR. Or did you find a solution?
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: iPrint Appliance 2 and TID 7017434

No I haven't found a solution, had to abandon the upgrade I was planning for the school holidays that just finished.
Unfortunately we don't have the funds to pay for support units so we were stuck at that point. If you open one, we'd love to hear the result of it!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

On 07/25/2016 11:26 PM, imoore wrote:
>
> No I haven't found a solution, had to abandon the upgrade I was planning
> for the school holidays that just finished.
> Unfortunately we don't have the funds to pay for support units so we
> were stuck at that point. If you open one, we'd love to hear the result
> of it!
>
>


There're various reasons to get the rpc 500 error with the patch 1 and
the empty printer list without patch 1. Basically it is the same issue:

1. If you create an appliance 2.0 new and you use a different name for
hostname and for iprint manager dns name, you'll see this issue. There
is an internal fix for it and it will be included on patch 2. If you can
not wait, open an sr and they will provide it to you

2. If you have imported an 1.1 configuration you will see this error if
hostname in 1.1 does not match the hostname in 2.0. One of the
requirements to migrate from 1.1 is that hostname should match on both
appliances. Same fix as point 1 is available

3. Another instance of this error will be seen with a migration if
hostname on both matches but print dns name is different than the
hostname on the 1.1 appliance. On the 1.1 appliance there was no problem
on having different names but it is/was an issue on 2.0. When you import
the 1.1 configuration, the iprint manager dns name from 1.1 will replace
the 2.0 name. Same fix point 1 and 2 is available

4. Certificates were expired on 1.1 prior to export the configuration.
When you import the 1.1 confirmation, the expired certificates are
imported as well and this will arise up when accessing the webconsole
and check the certificates again the one in 2.0. Recreating the
certificates in 2.0p using certman should fix it. See docs to sue
certman script

5. Tid7017851 shows another scenarios where the prc 500 error could be
seen. It is important to check iprintmobile0.log file and jetty log file
to see which trac eis showing in there as the rpc 500 is a very general
error

Basically all this issue will be fixed on patch 2 due within weeks
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

Can't add much more to what Mysterious wrote... Opened an SR and got a fix in the form of an RPM to be installed manually on the server console and now the issues are fixed. Patch 1 is installed, printers show in the list, no more RPC errors.
0 Likes
Highlighted
Micro Focus Contributor
Micro Focus Contributor

Re: iPrint Appliance 2 and TID 7017434

I just released this knowledgebase article that may help in this situation. https://www.novell.com/support/kb/doc.php?id=7017887
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

I installed patch 2 (531) and I still have the same issue. I also have the printer profile problem where newly created profiles don't show up on the list.
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: iPrint Appliance 2 and TID 7017434

I've applied the 2 FTF files mentioned in TID 7017887 and that fixed up the issues with printers not being listed on my system too.
I then installed HP2 for 2.0.0 and that all seems to have worked ok.
Since 2.1.0 is out now, I thought I'd try upgrading to that while I was at it, but I ran into a new problem with that:
The vm boots with the new 2.1.0 .img file for and finds and mounts the existing /vastorage image file and does the database upgrade - that part all appears to go according to plan. However, when I login to the appliance in a browser and get the iPrint Appliance Configuration screen, there is no "Previous appliance configuration found" message and if I click the Migrate option, I am prompted for the Configuration file & password, as if I am upgrading from 1.1.
As I said, the existing /vastorage partition is mounted and has data on it, so it should have detected the old config!
I've repeated the process several times with the same result.
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: iPrint Appliance 2 and TID 7017434

bobjohnson;2435601 wrote:
I just released this knowledgebase article that may help in this situation. https://www.novell.com/support/kb/doc.php?id=7017887


Are the two files that are mentioned in the article (fix_driver_store.sh and novell-iprint-mobile-2.0.0_FTF_985902-26.1.x86_64.rpm) still available to download? I get messages of "No such file" when I try to get them.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: iPrint Appliance 2 and TID 7017434

On 04/04/17 15:06, flauyven wrote:

> Are the two files that are mentioned in the article (fix_driver_store.sh
> and novell-iprint-mobile-2.0.0_FTF_985902-26.1.x86_64.rpm) still
> available to download? I get messages of "No such file" when I try to
> get them.


Given those two files were made available ~9 months ago no they're no
longer available and according to bug 985902 those fixes were included
in iPrint Appliance 2.0 Patch 2 which has since been superseded by
several subsequent patches.

If you are still seeing the issue addressed by TID 7017434 with the
latest iPrint Appliance 2.0 Patch 4 installed then I suggest upgrading
to iPrint Appliance 2.1 (with Hot Patch 4 installed). If you are still
then seeing the issue then you should submit a support request directly
with Micro Focus.

HTH.
--
Simon
Micro Focus Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iPrint Appliance 2 and TID 7017434

I have tried migrating from 1.1 to 2.1 hotpatch 4 and all the printers after migration you get submission failed when you try to print a job to them. Delete them and recreate them and then they work. None of the printer profiles are migrated and after migration when you create a printer profile it says successfully created but it will not appear if you try and assign it to a printer. Sorry if I sound a little frustrated but I don't think it should be this hard.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.