Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
5420 views

iPrint Authentication Failed....

My print server was just upgraded to Netware 6.5 sp7 and all went without
a hitch on the server, but we are experiencing some authentication issues
for secure printers only.

The server was running NDS version 8.7.3.7 before the upgrade and is now
running 8.7.3.9.

What happens is, when a person logs into the windows xp machine with any
novell client version, and they have a secure printer on their machine, it
has a window that comes up and says that Printer authentication has
failed, do you with to try again. I have the user click try again, and
then it pops up a windows to put their novell credentials in, which
doesn't work.

I have narrowed it down to something with the user accounts, not the
printers. I found out that if I create a new user, or if the user account
has been created in the past year or so, all works fine. If the user
account is an older account, it will not authenticate through now that we
have upgraded to SP7.

In the interim, I have created a temporary account called print that
everyone is putting in to authenticate to the printer until we can figure
this out.

Has anyone run into this issue, and if so how would I go about updating
the older user accounts to work with this new version of iPrint.

Thanks in advance.

0 Likes
14 Replies
Absent Member.
Absent Member.

Have you checked the "UniqueID" on the user, which is failing?

For iPrint, all user objects need the "uniqueID" attribute, which is not
generated using NWADmin. That could be the reason, why new users are
working, using C1 or iManager - the attribute is automatically generated,
but not with NWAdmin..

Steps to check:
open properties of the user in C1, goto "other" tab and check, if the
attribute uniqueID exists. If not, click "ADD" and add the Attribute with
the value of the Name - keep in mind, that it must be a unique Name in the
Tree!

Jürgen Blessing

Am Thu, 25 Oct 2007 14:45:01 +0000 schrieb Geoffrey O'Brien:

> My print server was just upgraded to Netware 6.5 sp7 and all went without
> a hitch on the server, but we are experiencing some authentication issues
> for secure printers only.
>
> The server was running NDS version 8.7.3.7 before the upgrade and is now
> running 8.7.3.9.
>
> What happens is, when a person logs into the windows xp machine with any
> novell client version, and they have a secure printer on their machine, it
> has a window that comes up and says that Printer authentication has
> failed, do you with to try again. I have the user click try again, and
> then it pops up a windows to put their novell credentials in, which
> doesn't work.
>
> I have narrowed it down to something with the user accounts, not the
> printers. I found out that if I create a new user, or if the user account
> has been created in the past year or so, all works fine. If the user
> account is an older account, it will not authenticate through now that we
> have upgraded to SP7.
>
> In the interim, I have created a temporary account called print that
> everyone is putting in to authenticate to the printer until we can figure
> this out.
>
> Has anyone run into this issue, and if so how would I go about updating
> the older user accounts to work with this new version of iPrint.
>
> Thanks in advance.


0 Likes
Absent Member.
Absent Member.

Thanks, that worked like a charm, I wish I saw this before I found it on
my own by comparing users in an ldap browser.

Jürgen Blessing wrote:

> Have you checked the "UniqueID" on the user, which is failing?


> For iPrint, all user objects need the "uniqueID" attribute, which is not
> generated using NWADmin. That could be the reason, why new users are
> working, using C1 or iManager - the attribute is automatically generated,
> but not with NWAdmin..


> Steps to check:
> open properties of the user in C1, goto "other" tab and check, if the
> attribute uniqueID exists. If not, click "ADD" and add the Attribute with
> the value of the Name - keep in mind, that it must be a unique Name in the
> Tree!


> Jürgen Blessing


> Am Thu, 25 Oct 2007 14:45:01 +0000 schrieb Geoffrey O'Brien:


>> My print server was just upgraded to Netware 6.5 sp7 and all went without
>> a hitch on the server, but we are experiencing some authentication issues
>> for secure printers only.
>>
>> The server was running NDS version 8.7.3.7 before the upgrade and is now
>> running 8.7.3.9.
>>
>> What happens is, when a person logs into the windows xp machine with any
>> novell client version, and they have a secure printer on their machine, it
>> has a window that comes up and says that Printer authentication has
>> failed, do you with to try again. I have the user click try again, and
>> then it pops up a windows to put their novell credentials in, which
>> doesn't work.
>>
>> I have narrowed it down to something with the user accounts, not the
>> printers. I found out that if I create a new user, or if the user account
>> has been created in the past year or so, all works fine. If the user
>> account is an older account, it will not authenticate through now that we
>> have upgraded to SP7.
>>
>> In the interim, I have created a temporary account called print that
>> everyone is putting in to authenticate to the printer until we can figure
>> this out.
>>
>> Has anyone run into this issue, and if so how would I go about updating
>> the older user accounts to work with this new version of iPrint.
>>
>> Thanks in advance.



0 Likes
Absent Member.
Absent Member.


Hi.

I have exactly the same problem.
Would you know some faster way to do 'userID' adding in eDir (i have more
than 1000 user objects created with NWAdmin)?

Please help...

Regards, KBorut
--------


Jürgen Blessing wrote:

> Have you checked the "UniqueID" on the user, which is failing?


> For iPrint, all user objects need the "uniqueID" attribute, which is not
> generated using NWADmin. That could be the reason, why new users are
> working, using C1 or iManager - the attribute is automatically generated,
> but not with NWAdmin..


> Steps to check:
> open properties of the user in C1, goto "other" tab and check, if the
> attribute uniqueID exists. If not, click "ADD" and add the Attribute with
> the value of the Name - keep in mind, that it must be a unique Name in the
> Tree!


> Jürgen Blessing


> Am Thu, 25 Oct 2007 14:45:01 +0000 schrieb Geoffrey O'Brien:


>> My print server was just upgraded to Netware 6.5 sp7 and ...



0 Likes
Absent Member.
Absent Member.

Yes, there are some LDAP tools available, and in C1, you can use
the Import/Export Tool, if you do a search on LDIFF / ICE in the
knoweledgebase, you will find some more information...

Jürgen

Am Mon, 29 Oct 2007 22:30:49 +0000 schrieb KBorut:

>
> Hi.
>
> I have exactly the same problem.
> Would you know some faster way to do 'userID' adding in eDir (i have more
> than 1000 user objects created with NWAdmin)?
>
> Please help...
>
> Regards, KBorut
> --------
>
>
> Jürgen Blessing wrote:
>
>> Have you checked the "UniqueID" on the user, which is failing?

>
>> For iPrint, all user objects need the "uniqueID" attribute, which is not
>> generated using NWADmin. That could be the reason, why new users are
>> working, using C1 or iManager - the attribute is automatically generated,
>> but not with NWAdmin..

>
>> Steps to check:
>> open properties of the user in C1, goto "other" tab and check, if the
>> attribute uniqueID exists. If not, click "ADD" and add the Attribute with
>> the value of the Name - keep in mind, that it must be a unique Name in the
>> Tree!

>
>> Jürgen Blessing

>
>> Am Thu, 25 Oct 2007 14:45:01 +0000 schrieb Geoffrey O'Brien:

>
>>> My print server was just upgraded to Netware 6.5 sp7 and ...


0 Likes
Absent Member.
Absent Member.

Which tools do you recommend? We are having this same issue and more users
than his 1000 to handle 🙂

0 Likes
Absent Member.
Absent Member.

Well, C1 should do the job with the Wizard |
Import / Export functionality, although you need to dig into how to create
the files and modify/reimport them. Other ldap tools might help as well:
http://www.novell.com/coolsolutions/tools/13976.html

Hope this helps and you find the information needed

Jürgen
0 Likes
Absent Member.
Absent Member.

Solved!

iManager LDAP export to file; little gymnastic with search&replace;
created import file with structure like:

#Sample
version: 1

dn: cn=TestUser1,ou=XTest,o=MyOrg
changetype: modify
add: uid
uid: TestUser1

dn: cn=TestUser2,ou=XTest,o=MyOrg
changetype: modify
add: uid
uid: TestUser2

...

LDAP import & it WORKED.



0 Likes
Absent Member.
Absent Member.

Either I don't have rights to export LDAP information or I just can't
figure out how to do it so that I can add the UniqueID tag to all users. A
little help here?


0 Likes
Absent Member.
Absent Member.

Anyone ??

0 Likes
Absent Member.
Absent Member.

LDAP Export was a typo, he means LDIF export. In ConsoleOne it's ICE in
the Tools menu, not sure of the exact location in iMan right now but
hopefully you will see it listed under ICE or LDIF or EXPORT somewhere ...
--
Andrew C Taubman
Novell Support Forums Volunteer SysOp
http://support.novell.com/forums
(Sorry, support is not provided via e-mail)

Opinions expressed above are not
necessarily those of Novell Inc.
0 Likes
Absent Member.
Absent Member.

ok, I installed the edir snapins for C1 and see the export option and am
trying to make it work.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.