Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Absent Member.
Absent Member.
2862 views

iPrint on Windows 7 32 Bit - Spooler and iPrint Client crash

Hey Everyone,

Iam sorry, I think this issue has been up here about a 1000 times (mostly relating to WinXP I think), but my knowledge of iPrint ist pretty close to zero and the support guys asked me if I could open up a thread in the novell forums.


My colleagues have encountered problems with the iPrint Client on Windows 7.
Iam not quite sure, that this issue is related to iPrint and Iam not really familiar with iPrint Administration / Support (Iam trying to get into this at the moment), so I will try to outline the problems. In the forums I could only find similar problems related with Windows XP with far older iPrint Versions than the ones we have in use.

We got about 15 Devices (running Windows 7) out of roundabout 1000 on which the Spooler Service and iPrint Client crashes. Leading to no printers being shown - and the user can not restart the Spooler Service.
This problem came up after the first devices were migrated to Win7.

So far everything the colleagues found out is:
This seems to be Hardware-independent and only happens on Win7 devices (Windows 7 32Bit).

This mainly happened on Workstations using iPrint Printers by HP, but on some devices there were Rico Printers installed. (But in all cases there were HP Printers set up via iPrint)

The HP Printers are either set up with UPD 5.1 Drivers or with Printerspecific Drivers. Changing the Drivers does not fix it in every case.
We are using UPD 5.1 because it was recommended to us. The latest versions seem to be buggy or something? If thats not the case, I can definetly try upgrading to 5.4 - Any experience with the 5.4 UPD?

There is only one device which more or less lets you reproduce the issue, in all other cases this seems to happen at random.
So at least I could get some logs etc...
Is there any way to troubleshoot the iPrint Client? So far I havent found any logs, but I will check the documentation as soon as Iam finished with my current project.

Sorry for posting such a typical Thread which should be rewarded with a "R.T.F.M.", but this matter is really urgent.

Client Side IPP: 5.74
Server OS: OES 2 SP3 on SLES 10
novell-iprint-iprntman-6.3.20110909-0.7
novell-iprint-server-6.3.20110909-0.7
yast2-novell-iprint-2.14.8-66
novell-iprint-client-6.3.20111110-0.9
novell-iprint-migration-6.3.20110909-0.7
novell-iprint-management-6.3.20110909-0.7

Once upon a time there was a guy named Ömse...
0 Likes
3 Replies
Absent Member.
Absent Member.

On 07/02/12 15:06, schiggieh wrote:
>
> Hey Everyone,
>
> Iam sorry, I think this issue has been up here about a 1000 times
> (mostly relating to WinXP I think), but my knowledge of iPrint ist
> pretty close to zero and the support guys asked me if I could open up a
> thread in the novell forums.
>
>
> My colleagues have encountered problems with the iPrint Client on
> Windows 7.
> Iam not quite sure, that this issue is related to iPrint and Iam not
> really familiar with iPrint Administration / Support (Iam trying to get
> into this at the moment), so I will try to outline the problems. In the
> forums I could only find similar problems related with Windows XP with
> far older iPrint Versions than the ones we have in use.
>
> We got about 15 Devices (running Windows 7) out of roundabout 1000 on
> which the Spooler Service and iPrint Client crashes. Leading to no
> printers being shown - and the user can not restart the Spooler
> Service.
> This problem came up after the first devices were migrated to Win7.
>
> SO FAR EVERYTHING THE COLLEAGUES FOUND OUT IS:
> This seems to be Hardware-independent and only happens on Win7 devices
> (Windows 7 32Bit).
>
> This mainly happened on Workstations using iPrint Printers by HP, but
> on some devices there were Rico Printers installed. (But in all cases
> there were HP Printers set up via iPrint)
>
> The HP Printers are either set up with UPD 5.1 Drivers or with
> Printerspecific Drivers. Changing the Drivers does not fix it in every
> case.
> We are using UPD 5.1 because it was recommended to us. The latest
> versions seem to be buggy or something? If thats not the case, I can
> definetly try upgrading to 5.4 - Any experience with the 5.4 UPD?
>
> There is only one device which more or less lets you reproduce the
> issue, in all other cases this seems to happen at random.
> So at least I could get some logs etc...
> Is there any way to troubleshoot the iPrint Client? So far I havent
> found any logs, but I will check the documentation as soon as Iam
> finished with my current project.
>
> Sorry for posting such a typical Thread which should be rewarded with a
> "R.T.F.M.", but this matter is really urgent.
>
> Client Side IPP: 5.74
> Server OS: OES 2 SP3 on SLES 10
> novell-iprint-iprntman-6.3.20110909-0.7
> novell-iprint-server-6.3.20110909-0.7
> yast2-novell-iprint-2.14.8-66
> novell-iprint-client-6.3.20111110-0.9
> novell-iprint-migration-6.3.20110909-0.7
> novell-iprint-management-6.3.20110909-0.7
>
>


did you apply this hot-fixes from Microsoft?: if not, you have to do so


http://support.microsoft.com/kb/2511290
http://support.microsoft.com/kb/2546651

0 Likes
Absent Member.
Absent Member.

Hey Mysterious,

I will check this right away, thanks for your tipp! 🙂

Once upon a time there was a guy named Ömse...
0 Likes
Ensign
Ensign

Thank you Mysterious for the hotfix references, hopefully that will solve my
issue. But, for the HP printers, you may also want to check the firmware
loaded on those printers. We had some issues with printing and HP advised
that the latest UPD releases are not too compatible with the older
firmware-- particularly with PDF docs but also with Word, like dropping the
last few lines of print, delays in printing that could be as long as 60
minutes due to a lack of response from the printer, I am not sure I remember
all of the individual complaints. In fact, I have another incident open
with HP because printing PDF selecting 2 pages/sheet prints 2 black boxes
using WIN 7 or WIn xp, Iprint or no.

"schiggieh" wrote in message
news:schiggieh.57kl7b@no-mx.forums.novell.com...


Hey Mysterious,

I will check this right away, thanks for your tipp! 🙂


--
Once upon a time there was a guy named �mse...
------------------------------------------------------------------------
schiggieh's Profile: http://forums.novell.com/member.php?userid=55814
View this thread: http://forums.novell.com/showthread.php?t=451928

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.