Highlighted
Absent Member.
Absent Member.
4964 views

iprintgw high CPU utilizatoin

We have a recurring problem on two of our OES 11.1 servers where iprintgw, presumably novell-ipsmd, is running away with CPU utilization. Eventually, this causes iPrint to stop working altogether until I restart the process. Sometimes, people are still able to print while the high utilization is going on, but eventually people can no longer print.

Currently, according to top, overall CPU utilization on one server is hovering around 50%. The iprintgw command is at the top of the list and is supposedly taking around 150-193% of CPU (not sure how it can be over 100%).

The problems appear to have begun after a fairly recent software update, although I cannot say for sure.

This is a real problem for us, as we have multiple schools sharing print managers, so when one stops responding, it creates a pretty big problem. Anybody have any ideas?

Rick P
Walla Walla Public Schools
0 Likes
14 Replies
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

One thing to add . . .

I looked in iprintgw.log, and I see a number of warning messages that end in "Error 32 - Broken pipe". I don't know if these are related to our problem. Anybody know something about this error?

Here is the full text of one of the errors:
Oct 21 12:16:36 WARNING 10/21/13 12:16:36 CommWrite failed for printer agent 'GP 1st Grade Common', Error 32 - Broken pipe
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

On 10/22/2013 12:56 AM, RPummel wrote:
>
> One thing to add . . .
>
> I looked in iprintgw.log, and I see a number of warning messages that
> end in "Error 32 - Broken pipe". I don't know if these are related to
> our problem. Anybody know something about this error?
>
> Here is the full text of one of the errors:
> Oct 21 12:16:36 WARNING 10/21/13 12:16:36 CommWrite failed for printer
> agent 'GP 1st Grade Common', Error 32 - Broken pipe
>
>


Known issue with latest iprint code. novell has an internal FTF with the
fix. open a sr and referrers to Bug 834863 - High utilization in the
latest iPrintGW from
novell-iprint-server-6.5.1.20130712-0.3.102.x86_64.rpm or backreview to
April 2013 scheduled maintenance build
(novell-iprint-server-6.3.20130213-0.7) or EARLIER.

November maintenance patch will contain the fix.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

Hello,
We have some problem (novell-iprint-server-6.5.1.20130917-0.3.1) , any news about fix ?
Thanks
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: iprintgw high CPU utilizatoin

On 31/10/2013 11:36, kimmeriya wrote:

> We have some problem (novell-iprint-server-6.5.1.20130917-0.3.1) , any
> news about fix ?


As Mysterious said on 22-Oct-2013:

"Known issue with latest iprint code. novell has an internal FTF with
the fix. open a sr and referrers to Bug 834863 - High utilization in the
latest iPrintGW from
novell-iprint-server-6.5.1.20130712-0.3.102.x86_64.rpm or backreview to
April 2013 scheduled maintenance build
(novell-iprint-server-6.3.20130213-0.7) or EARLIER.

November maintenance patch will contain the fix."

So you either need to back rev' novell-iprint-server or wait for the
November Scheduled Maintenance patch set (which will not necessarily be
released in November - could be beginning of December based on previous
patch release dates).

HTH.
--
Simon
Novell Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: iprintgw high CPU utilizatoin

And what's the safest way to backrev your iprint software? I'm running the version that just came out - novell-iprint-server-6.5.1.20130917-0.3.1.

Thanks,

Alan
0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: iprintgw high CPU utilizatoin

We were having this issue when running novell-iprint-server-6.5.1.20130430-0.3.4. We backrev'd to novell-iprint-server-6.5.1.20130213-0.3.42 ( as released in April 2013 Scheduled Maintenance for OES11SP1 ).

To do this we backed up our iprint system, then did:

rpm -Uvh --force novell-iprint-server-6.5.1.20130213-0.3.42.x86_64.rpm

This performs an "upgrade" of iPrint, but going back a version. We restarted our iPrint services, and everything was fine. After opening a call with Novell we're now running on the FTF, which as stated before is to be included in the November Scheduled Maintenance patch.

Ant
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: iprintgw high CPU utilizatoin

Thanks!

Alan
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

We just encountered this issue with the May 2014 OES11SP2 Maintenance update 9157. We just rolled-back to novell-iprint-server-6.7.0.20131126-0.5.8 October 2013 release and it seems to be working again. It took a couple days for it to have this problem.

Anyone else have this problem with the May 2014 release?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

tsuba;2322690 wrote:
We just encountered this issue with the May 2014 OES11SP2 Maintenance update 9157. We just rolled-back to novell-iprint-server-6.7.0.20131126-0.5.8 October 2013 release and it seems to be working again. It took a couple days for it to have this problem.

Anyone else have this problem with the May 2014 release?


Yes we are seeing this problem with the May 2014 release (6.5.1.20140516-0.3.4) I think I will need to try to backrev.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

We are running novell-iprint-server-6.7.0.20140516-0.5.1 and seeing the same issue. Can anyone tell me where I can find the novell-iprint-server-6.7.0.20131126-0.5.8 October 2013 release package?
Thank you!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: iprintgw high CPU utilizatoin

On 10/09/2014 03:06 PM, robs609 wrote:
>
> We are running novell-iprint-server-6.7.0.20140516-0.5.1 and seeing the
> same issue. Can anyone tell me where I can find the
> novell-iprint-server-6.7.0.20131126-0.5.8 October 2013 release package?
> Thank you!
>
>


The fix for this issue is not yet released. It will be on the OES
November maintenance patch. Till then, open a sr with novell and ask for
the internal rpm with the fix.
or apply workaround from tid7015475
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.